Multidimensional Bioimage Analysis

Chong Zhang
chong.zhang@upf.edu
https://portal.upf.edu/web/bia

SIMBioSys, Department of Information and Communication Technologies
Universitat Pompeu Fabra

30th June, 2016
Overview

- Multidimensional image
- Fiji: Stack manipulation
- Fiji: 3D image reconstruction and visualization (volume & surface rendering)
- Fiji: An application study: 3D image analysis (+ macro scripting)
Images can have many dimensions

The number of dimensions is the number of things you need to know to find each pixel

To find a pixel, you need:

- 0 dimensions (just a single pixel)
Images can have many dimensions

The number of dimensions is the number of things you need to know to find each pixel.

To find a pixel, you need:

- \( x \) coordinate
  
1 dimension
(can be plotted as a graph)

\( x \)
Images can have many dimensions

The number of dimensions is the number of things you need to know to find each pixel

To find a pixel, you need:
- x coordinate
- y coordinate
  (xy)

2 dimensions
Images can have many dimensions

The number of dimensions is the number of things you need to know to find each pixel.

To find a pixel, you need:
- x coordinate
- y coordinate
- Colour channel
  (xyc or xyz for 3D)

3 dimensions

Slide courtesy: P. Bankhead
Images can have many dimensions

The number of dimensions is the number of things you need to know to find each pixel.

To find a pixel, you need:
- x coordinate
- y coordinate
- Colour channel
- z plane
  (ordians or izxy)

4 dimensions
Images can have many dimensions

The number of dimensions is the number of things you need to know to find each pixel.

To find a pixel, you need:
- x coordinate
- y coordinate
- Colour channel
- z plane
- Time point

(xyczt or other ordering)

5 dimensions

Slide courtesy: P. Bankhead
**Stack & Hyperstack**

**Stack:** a set of related images of the same size and bit depth (*xyz* or *xyt*).

**Slices:** the images that make up a stack

**Voxel:** volumetric image element

**Hyperstack:** When more dimensions are combined into a stack, i.e. four (4D) or five (5D) dimensions: *x* (width), *y* (height), *z* (slices), *c* (channels or wavelengths) and *t* (time frames).

In Fiji, hyperstacks are commonly displayed in a window with up to three scrollbars.
Other Fiji plugin (hyperstack) viewers

- LOCI Data Browser: [http://loci.wisc.edu/software/data-browser](http://loci.wisc.edu/software/data-browser)
- View5D: [http://www.nanoimaging.de/View5D](http://www.nanoimaging.de/View5D)
- Image5D: [http://imagej.net/Image5D](http://imagej.net/Image5D)
Projections: "flatten" high dimensional stack

**Projections:** output a single image that results from a calculation at each pixel location over all images in the stack

![Stack of images](imagej.net/Z-functions)

- **Average:** each pixel stores the average intensity over all slices at the particular location
- **Maximum/Minimum:** each pixel stores the maximum/minimum value over all slices at the particular location
- **Sum Slices:** sum all the slices in the stack
- **Standard deviation:** standard deviation of all the slices in the stack
- **Median:** each pixel stores the median intensity over all slices at the particular location
Exercise - Projections: "flatten" 3D stack

1. [File > Open > moving_dot.tif]
2. [Image > Stacks > Z Project]

http://imagej.net/Z-functions
3D Projection (for rendering)

1. [File > Open Samples > T1 Head]
2. [Image > Stacks > 3D Project…]

Color coding – temporal/depth coding

1. [EMBL > Samples > Listeriacells.tif]
2. [Image > Hyperstack > Temporal Color Code]

http://imagej.net/Temporal-Color_Code

Slide courtesy: K. Miura
Plot Mean grey value vs Slice number

1. [EMBL > Samples > virus]
2. [Image > Stack > Plot Z-axis Profile]
Open/Import stacks

[File > Import > Image Sequence...]

or

[File > Import > Bio-Formats]

[Image > Stacks > Animation > animation options]

Open example image at [Stk > MRI stack] to play a bit with the functionalities available
Stack-Slice Manipulation

- Add Slice
- Delete Slice
- Next Slice [>] 
- Previous Slice [<] 
- Set Slice...

Images to Stack
- Stack to Images
- Make Montage...

Reslice [/]...
- Orthogonal Views  
- Z Project...
- 3D Project...
- Plot Z-axis Profile
- Label...
- Statistics
- Animation
- Tools

Combine...
- Concatenate...
- Reduce...
- Reverse
- Insert...
- Montage to Stack...
- Make Substack...
- Grouped Z Project...
- Set Label...
- Remove Slice Labels

Slice Remover
- Slice Keeper
- Stack Sorter
- Stack Splitter
- Interleave
- Deinterleave

Images to Stack
- Stack to Images

Stack Reverser
- Make Substack Ex: 1, 3, 6-8

Montage
- Slice Keeper or Slice Remover
- Ex: Start 2 Increment 3

Montage to Stack or Stack Maker

http://imagej.net/Stack-slice_Manipulations

Slide courtesy: S. Tosi
Stack-Slice Manipulation

[ Image > Stacks ]
[ Image > Stacks > Tools ]

- Concatenate
- Combine
- Interleave
- Deinterleave
- Stack Splitter (ex: x4)
- Stack Inserter (x,y coordinates)

Slide courtesy: S. Tosi

http://imagej.net/Stack-slice_Manipulations
Exercise - Stack-Slice Manipulation

1. [File > New > Image...]
   - Type: 8-bit
   - Fill with: Black
   - Width: 200
   - Height: 200
   - Slices: 10

2. [Image > Stacks > Time Stamper]
   - Play with X/Y location & font size (70, 90, 30)

3. [Image > Stacks > Make Montage...]
   - Columns: 5
   - Rows: 2
   - Border Width: 1
   - Label Slices: On

4. Deleting every second frame
   [Image > Stacks > Tools > Slice Remover]
   Fist/Last slice, increment: 2,10,2

5. Duplicate the stack, Invert the stack order and combine them side by side to make a single stack.
   [Image > Stacks > Tools > Reverse]
   [Image > Stacks > Tools > Combine...]
   - Select the two stacks
   - Untick Combine vertically
1. [EMBL > Samples > Mitosis_4D.tif]
   - Find out hyperstack dimensions
2. [Image > Hyperstacks > Re-order Hyperstacks…]
3. Extract substack of 3D anaphase at time point 11
   [Image > Stacks > Tools > Make Substack…]
   Slices: 1-16, Frames: 11
   Or from original hyperstack:
   Slices: 161-176-1
4. Change voxel depth to 5
   [Image > Properties…]
   Voxel depth: 5
5. [Plugins > 3D Viewer]
   - Display as: Surface
   - Color: Red
   - Threshold: 41
   - Resampling factor: 1
6. Try Mitosis_4D.tif to view a time series in the 3D viewer
Exercise – 3D Viewer

1. [File > Open Samples > flybrain.tif]
2. Split channels, and save the red and green channels
3. [Plugin > 3D Viewer]
   - Image: flybrain.tif (green)
   - Display as: volume
   - Color: green
4. [Add > From Image]
   - Image: flybrain.tif (green)
   - Display as: surface
   - Name: mesh
   - Color: white
   - Threshold: 100
5. [Edit > Select > flybrain.tif (green)], rotate/translate it
   [Edit > Select > flybrain.tif (green)], rotate/translate it
   select each object, do [Edit > Transformation > Reset Transformation]
   unselect any object
6. Select flybrain.tif (green), [Edit > Change Transparency], play till satisfied
   Select mesh, [Edit > Change Color] to blue, and play with transparency till satisfied, you can also [Edit > Adjust threshold]
7. [Add > From Image]
   - Image: flybrain.tif (red)
   - Display as: volume
   - Color: red
   [View > Change animation options], rotate around Y-axis, rotation interval: 5 degrees
   [View > Record 360 degree animation] or [View > Start freehand recording] then stop
   change the animation speed to 15 fps
8. Select 3D Viewer, select mesh, [Edit > Delete]

If you want, they can be recorded as macro!
Orthogonal Views

1. [File > Open Samples > T1 Head]
2. [Image > Stacks > Orthogonal views]
3. [Plugins > Volume Viewer]
1. [File > Open Samples > T1 Head]
2. [Image > Stacks > Reslice]
Volume rendering – color coding

(Binary) volume

Local thickness estimate
[Analyze > Local Thickness]
3D visualization tools

**Proprietary software:**
Imaris (Bitplane), Volocity (Perkin Elmer), Amira (Visualization Sciences Group), Huygens (Scientific Volume Imaging), …

**Free software:**
ImageJ, Fiji, Icy, Vaa3D, ImageSurfer, BioImageXD, Paraview, Volview, …

**ImageJ / Fiji plugins:**
3D Viewer, Volume viewer, VolumeJ
Exercise – Segment 3D spots

0. ([ Plugins > Macros > Record ])
1. [ Open > GFP neurons spines.tif ]
2. [ Plugins > Feature Extraction > FeatureJ > FeatureJ Laplacian ]
   • apply the filter with a smoothing scale of 2
3. On the filtered image: [ Image > Adjust > Threshold ]
   • un-tick set background pixels to NaN
   • un-tick “calculate threshold for each image”
   • if wish background as white, un-tick “black background”
   • apply the threshold
4. [ Process > Binary > Fill holes ]
5. [ Analyze > 3D OC Options ]
   • tick the interested measurements.
   • tick “show masked image” & select the original stack in the “redirect to” drop down menu.
   • untick “show numbers”.
6. [ Analyze > 3D objects counter ]
   • threshold: 128; minimum size filter: 5 voxels
   • tick objects, statistics and summary
7. ([ Analyze > Tools > Sync windows ])
   • Explore objects map stack (1 color per object) together with the original image

http://imagescience.org/meijering/software/featurej/
3D Manager

- Geometry based measurements
  - Distances between each two objects of the selected ones
- Intensity based measurements
  - Measure 3D
  - Quantif 3D
- Angles between 3 selected regions. Each is calculated with the selected object in the center.
- Fill selected objects regions with current intensity value into current image

When selected, objects are highlighted in image

Add 3D labelled image, binary image, etc.

Create 3D labelled image from binary image

Delete both from list and image

Fill selected objects regions with current intensity value into current image

3D processing/analysis filters

3D ImageJ Suite

This suite provides plugins to enhance 3D capabilities of ImageJ.

Author

Thomas Boulier (thomas dot boulier at any dot juiscu dot fr) @Cellular Modeling and Biological Imaging.

With many contributions from J. Oliffen (MINHN USM0509).

Features

This suite is composed of:

- 3D Filters (mean, median, max, min, tophat, max local, ...)
- 3D Segmentation (hysteresis thresholding, spots segmentation, watershed, ...)
- 3D Mathematical Morphology tools (fill holes, binary closing, distance map, ...)
- 3D RoleManager (3D display and analysis of 3D objects)
- 3D Analysis (Geometrical measurements, Mesh measurements, Convex hull, ...)
- 3D MeroTopology (Relationship between objects)
- 3D Tool (Drawing displacements and lines, cropping, ...)

A 2D/3D spatial statistics plugin is also available.

Installation

Download and copy the following jars in your plugins folder or alternatively download the http://bundle 2.6 and unzip it in your plugins folder. The various plugins provided in your 3D ImageJ Suite can be accessed from the ImageJ menu

You have also to manually download and copy into your plugins directory the ImageScience.jar library from: http://www.imagescience.org/sejering.zip

Exercise – 3D quantification with macro

To write a script using this plugin we need to look at its own macros functions.

<table>
<thead>
<tr>
<th>AddImage</th>
<th>Adds the objects in the current labeled image to the list</th>
</tr>
</thead>
<tbody>
<tr>
<td>Count</td>
<td>Get the number of objects</td>
</tr>
<tr>
<td>Select</td>
<td>Select an object (behavior depends on select mode, see monoselect and multiselect)</td>
</tr>
</tbody>
</table>

Write a script to colorize the objects based on their volume. Remember, you can use the macro recorder.

```java
1 waitForUser("Select the image with the objects to colorize");
2 w=getWidth();
3 h=getHeight();
4 s=nSlices();
5 run("3D Manager");
6 Ext.Manager3D_AddImage();
7 run("3D Manager Options", "volume compactness mean grey value std");
8 Ext.Manager3D_Measure();
9 selectWindow("3D Measure");
10 IJ.renameResults("3D Measure", "Results");
11 newImage("color size", "8-bit black", w, h, s);
12 selectWindow("color size");
13 vtab=newArray(nResults);
14 for (i=0; i<nResults; i++)
15 vtab[i]=getResult("Vol (unit)", i);
16 Array.getStatistics(vtab, vmin, vmax, vmean, vstd);
17 for (i=0; i<nResults; i++) {
18 Ext.Manager3D_Select(i);
19 v=getResult("Vol (unit)", i);
20 r=(v-vmin)/(vmax-vmin);
21 Ext.Manager3D_FillStack(255*r, 255*r, 255*r);
22 }
23 run("Fire");
24 setSlice(s/2+1);
25 run("Enhance Contrast", "saturated=0.35");
26 print("finished!");
```

ImageJ macro functions related to results in a table only work if the table is called “Results”

Storing all volume measurements in an array allows us to later obtain the statistics.

Calculate normalized voxel size, and store it to each object in the new stack.
September 12, 13 morning (optional)

ilastik (http://ilastik.org) simple, user-friendly interactive tool image classification segmentation up to 5D track animals and dividing objects count without detection

September 13-16

NEUBIAS training school for facility staff

Application deadline: July 15!
Application: http://bit.ly/294a0Cg

Day 1 (Sep 13th, Tue)
- Introduction & workflows in BioImage analysis
- Introduction to ImageJ macro language
- Segmentation, operations with binary images, task automation
- Image restoration (background subtraction, denoising, deconvolution...)

Day 2 (Sep 14th, Wed)
- 3D Colocalization analysis
- 3D Blood vessels segmentation, network analysis and measurements
- *Meet the taggers 1*: opportunity to meet bioimage analysts working to build new NEUBIAS resources (see Taggathon)
- Social dinner with taggers

Day 3 (Sept 15th, Thu)
- Introduction to Matlab
- Image processing and data analysis with Matlab
- *Meet the taggers 2*: opportunity to meet bioimage analysts working to build new NEUBIAS resources (see Taggathon)
- Social dinner with taggers

Day 4 (Sept 16th, Fri)
- Directionality analysis of EB1 movement along microtubules (ImageJ + Matlab)
- Advanced visualization and registration of large data, ImageJ BigData Viewer
- Open session: *Present your problem, code your workflow, get help from trainers*
Thank You!

Chong Zhang
chong.zhang@upf.edu
https://portal.upf.edu/web/bia

30th June, 2016